Video & Network Troubleshooting

Mobile and Tablets

Last Updated -

iOS
AHLTV App is required. Click HERE to download the app.
Requires iOS 9.0 or later. Compatible with iPhone, iPad and iPod touch

Android
AHLTV app is required. Click HERE to download the app.
Requires Android 4.1 and up.  

Still Need Help?

No worries, our all star support team is standing by!